Back to overview
Downtime
Some services are unavailable
Feb 25 at 11:22am HST
Affected services
explorer.frontrx.com
Main Service
Consultation Service
Resolved
Feb 25 at 11:49am HST
Services are working again. We are still investigating the cause of downtime.
Affected services
explorer.frontrx.com
Main Service
Consultation Service
Created
Feb 25 at 11:22am HST
We are investigating the issue.
Affected services
explorer.frontrx.com
Main Service
Consultation Service